Posted by: Yell | 3 มีนาคม 2010

Snow Leopard Java Problem

The new Snow Leopard is forced to use 64 bit Java 6 VM. Some Java application couldn’t be used under this environment. If your old application require Java 5 VM, used this step to downgrade the Java VM for application compatibility.

  1. Download
  2. Extract the file by double click the downloaded file.
  3. Go to Terminal
  4. cd Downloads
  5. sudo mv 1.5.0 /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0-leopard
  6. cd /System/Library/Frameworks/JavaVM.framework/Versions/
  7. sudo rm 1.5.0
  8. sudo ln -s 1.5.0-leopard 1.5.0
  9. open “/Applications/Utilities/Java”
  10. At the Java Application section, move the J2SE 5.0 32-bit to the first priority
  11. Now you can use your old Java application under the new Snow Leopard


Please log in using one of these methods to post your comment: Logo

You are commenting using your account. Log Out / เปลี่ยนแปลง )

Twitter picture

You are commenting using your Twitter account. Log Out / เปลี่ยนแปลง )

Facebook photo

You are commenting using your Facebook account. Log Out / เปลี่ยนแปลง )

Google+ photo

You are commenting using your Google+ account. Log Out / เปลี่ยนแปลง )

Connecting to %s


%d bloggers like this: